Opened 5 months ago

Closed 5 months ago

#1086 closed defect (duplicate)

miss "else" in function transform_tree()

Reported by: annci Owned by:
Priority: minor Milestone:
Component: spec Version:
Keywords: Cc: ksuehring, bbross, XiangLi, fbossen, jvet@…

Description

It seems to miss "else" in function transform_tree() on JVET-R2001-V10-H266.docx.

transform_tree() on JVET-R2001-V10-H266.docx:
transform_tree( x0, y0, tbWidth, tbHeight , treeType, chType ) {

InferTuCbfLuma = 1
if( IntraSubPartitionsSplitType = = ISP_NO_SPLIT && !cu_sbt_flag ) {

if( tbWidth > MaxTbSizeY | | tbHeight > MaxTbSizeY ) {

verSplitFirst = ( tbWidth > MaxTbSizeY && tbWidth > tbHeight ) ? 1 : 0
trafoWidth = verSplitFirst ? ( tbWidth / 2 ) : tbWidth
trafoHeight = !verSplitFirst ? ( tbHeight / 2 ) : tbHeight
transform_tree( x0, y0, trafoWidth, trafoHeight, treeType, chType )
if( verSplitFirst )

transform_tree( x0 + trafoWidth, y0, trafoWidth, trafoHeight, treeType, chType )

else

transform_tree( x0, y0 + trafoHeight, trafoWidth, trafoHeight, treeType, chType )

transform_unit( x0, y0, tbWidth, tbHeight, treeType, 0, chType )

}

} else if( cu_sbt_flag )

.........
change to:

transform_tree( x0, y0, tbWidth, tbHeight , treeType, chType ) {

InferTuCbfLuma = 1
if( IntraSubPartitionsSplitType = = ISP_NO_SPLIT && !cu_sbt_flag ) {

if( tbWidth > MaxTbSizeY | | tbHeight > MaxTbSizeY ) {

verSplitFirst = ( tbWidth > MaxTbSizeY && tbWidth > tbHeight ) ? 1 : 0
trafoWidth = verSplitFirst ? ( tbWidth / 2 ) : tbWidth
trafoHeight = !verSplitFirst ? ( tbHeight / 2 ) : tbHeight
transform_tree( x0, y0, trafoWidth, trafoHeight, treeType, chType )
if( verSplitFirst )

transform_tree( x0 + trafoWidth, y0, trafoWidth, trafoHeight, treeType, chType )

else

transform_tree( x0, y0 + trafoHeight, trafoWidth, trafoHeight, treeType, chType )

}
else{

transform_unit( x0, y0, tbWidth, tbHeight, treeType, 0, chType )

} else if( cu_sbt_flag )

.........

Change history (1)

comment:1 Changed 5 months ago by vdrugeon

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #895.

Note: See TracTickets for help on using tickets.