Opened 5 months ago

Closed 4 months ago

#1091 closed defect (duplicate)

Unnecessary description of default behavior

Reported by: deluxan Owned by:
Priority: minor Milestone:
Component: spec Version:
Keywords: Cc: ksuehring, bbross, XiangLi, fbossen, jvet@…

Description

The intra_subpartitions_split_type syntax element is described as

intra_subpartitions_split_flag[ x0 ][ y0 ] specifies whether the intra subpartitions split type is horizontal or vertical. When intra_subpartitions_split_flag[ x0 ][ y0 ] is not present, it is inferred as follows:
– If cbHeight is greater than MaxTbSizeY, intra_subpartitions_split_flag[ x0 ][ y0 ] is inferred to be equal to 0.
– Otherwise (cbWidth is greater than MaxTbSizeY), intra_subpartitions_split_flag[ x0 ][ y0 ] is inferred to be equal to 1.

It can be seen that the default behaviour of the element when it is not present depends on cbHeight and cbWidth. This was necessary in the past, but after the adoption of JVET-N0308 ISP can only be used if both cbWidth and cbHeight are less than or equal to MaxTbSizeY. Therefore, the default behavior when it is not present is unnecessary and therefore it can be simplified to the following:

When intra_subpartitions_split_flag[ x0 ][ y0 ] is not present, it is inferred to be 0.

Change history (1)

comment:1 Changed 4 months ago by bbross

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #951.

Note: See TracTickets for help on using tickets.