Opened 4 months ago

Closed 4 months ago

#1137 closed defect (duplicate)

Wrong range check for delta_chroma_offset_l0[ i ][ j ]

Reported by: hbteo Owned by:
Priority: minor Milestone:
Component: VTM Version: VTM-9.0
Keywords: Cc: ksuehring, XiangLi, fbossen, jvet@…

Description

Spec description:
"The value of delta_chroma_offset_l0[ i ][ j ] shall be in the range of −4 * 128 to 4 * 127, inclusive. When chroma_weight_l0_flag[ i ] is equal to 0, ChromaOffsetL0[ i ][ j ] is inferred to be equal to 0."

VTM implementation:
READ_SVLC( iDeltaChroma, iNumRef==0?"delta_chroma_offset_l0[i]":"delta_chroma_offset_l1[i]" );
CHECK( iDeltaChroma < -4*range, "delta_chroma_offset_lx shall be in the range of -4 * 128 to 4 * 127" );
CHECK( iDeltaChroma >= 4*range, "delta_chroma_offset_lx shall be in the range of -4 * 128 to 4 * 127" );

Should be:
CHECK( iDeltaChroma >= 4*(range - 1), "delta_chroma_offset_lx shall be in the range of -4 * 128 to 4 * 127" );

Change history (2)

comment:2 Changed 4 months ago by hbteo

  • Resolution set to duplicate
  • Status changed from new to closed

Yes, you are right. Closed as duplicate of MR1670.

Note: See TracTickets for help on using tickets.