Opened 8 months ago

Closed 8 months ago

#1401 closed defect (fixed)

VPS m_numReorderPics[j] initialization issue

Reported by: rickxu Owned by:
Priority: minor Milestone: VTM-10.1
Component: VTM Version: VTM-10.0
Keywords: Cc: ksuehring, XiangLi, fbossen, jvet@…

Description

A conformance issue was reported in ticket "https://jvet.hhi.fraunhofer.de/trac/vvc/ticket/1398". This issue was caused by a VTM10.0 code bug in initializing m_numReorderPics[j] in xInitVPS(). The below code

m_vps->m_dpbParameters[dpbIdx].m_numReorderPics[j] = m_vps->m_dpbParameters[dpbIdx].m_maxDecPicBuffering[j];

should be changed to

m_vps->m_dpbParameters[dpbIdx].m_numReorderPics[j] = m_vps->m_dpbParameters[dpbIdx].m_maxDecPicBuffering[j] - 1;

to comply with the Spec constraint that "The value of dpb_max_num_reorder_pics[ i ] shall be in the range of 0 to dpb_max_dec_pic_buffering_minus1[ i ], inclusive. "

Change history (2)

comment:2 Changed 8 months ago by fbossen

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.