Opened 4 years ago

Closed 2 years ago

#1415 closed defect (fixed)

Decoder crashed after !1927 (JVET-S0078-Rebased: Handling NoOutputOfPriorPicFlag) when encountering a second IDR picture

Reported by: ksuehring Owned by:
Priority: major Milestone:
Component: VTM Version: VTM-11.0
Keywords: Cc: ksuehring, XiangLi, fbossen, jvet@…

Description

When a second IDR is encountered in a bitstream xFlushOutput() is called, which deletes the just decoded IDR picture. Further decoding fails trying to access the picture.

Change history (6)

comment:1 Changed 4 years ago by ksuehring

A bitstream for reproducing the problem can be created with the "--DecodingRefreshType=2" encoder parameter.

comment:2 Changed 4 years ago by hendry197

MR!1937 has been submitted to fix this problem

comment:3 Changed 2 years ago by fbossen

Do we have a bitstream to test this?

comment:4 Changed 2 years ago by fbossen

  • Version set to VTM-11.0

comment:5 Changed 2 years ago by ksuehring

If I remember correctly, the issue only appeared after the implementation of JVET_S0078_NOOUTPUTPRIORPICFLAG. We disabled the macro as a work around. MR !1937 was created to fix the issue, but caused other software crashes and was thus not merged.

it seem the macro JVET_S0078_NOOUTPUTPRIORPICFLAG was accidentally removed in 07bf3979927f70760d5c303cd9b7eaba0fb4ddf4 along with the whole handling of no_output_of_prior_pics_flag.

So the issue does not exist in current VTM anymore, but als the implementation of JVET-S0078 is missing.

So it's probably fine to close the issue. We should make sure to have JVET-S0078 on the list of missing implementations though.

I think the RAP_C_HHI and RAP_D_HHI would have triggered the crash because they contain more than one IDR pictures.

comment:6 Changed 2 years ago by fbossen

  • Resolution set to fixed
  • Status changed from new to closed

Updated the integration status of S0078 in the tracking sheet. Closing this since it was related to an integration that was reverted.

Note: See TracTickets for help on using tickets.