Opened 3 months ago

#1487 new defect

potential bug in void EncSampleAdaptiveOffset::deriveLoopFilterBoundaryAvailibility() of VTM13.0

Reported by: zhou Owned by:
Priority: minor Milestone:
Component: VTM Version:
Keywords: Cc: ksuehring, XiangLi, fbossen, jvet@…

Description

I am wondering whether "isSameTile" should be replaced with "isSameSlice" in the following code

if (!isLoopFiltAcrossSlicePPS)
{

isLeftAvail = (cuLeft == NULL) ? false : CU::isSameTile(*cuCurr, *cuLeft);
isAboveAvail = (cuAbove == NULL) ? false : CU::isSameTile(*cuCurr, *cuAbove);
isAboveLeftAvail = (cuAboveLeft == NULL) ? false : CU::isSameTile(*cuCurr, *cuAboveLeft);

}
else
{

isLeftAvail = (cuLeft != NULL);
isAboveAvail = (cuAbove != NULL);
isAboveLeftAvail = (cuAboveLeft != NULL);

}

Change history (0)

Note: See TracTickets for help on using tickets.