Opened 11 months ago

Closed 3 months ago

#1540 closed defect (wontfix)

Decoder runs into exception at the end of bit stream

Reported by: guichunli Owned by:
Priority: minor Milestone:
Component: VTM Version:
Keywords: Cc: ksuehring, XiangLi, fbossen, jvet@…

Description

When testing VTM-16.0rc1 decoder in debug mode and turn on "break on all C++ exceptions" in Visual Studio, the following exception is triggered at the end of the bitstream (as attached).
The exception was triggered in function eofBeforeNBytes().

Command lines to reproduce this issue:
EncoderApp -c cfg\encoder_randomaccess_vtm.cfg --InputFile=BQSquare_416x240_60.yuv --BitstreamFile=Bin_enc.bin --SourceWidth=416 --SourceHeight=240 --QP=37 --FrameSkip=0 --FramesToBeEncoded=17 --IntraPeriod=96 --FrameRate=60 --InputBitDepth=8 --ReconFile=recon.yuv --SEIDecodedPictureHash=1

DecoderApp -b Bin_enc.bin -o decoded.yuv --SEIDecodedPictureHash=1

Attachments (2)

Bin_enc.bin (10.9 KB) - added by guichunli 11 months ago.
Bitstream file
exception.png (33.5 KB) - added by guichunli 11 months ago.
Screenshot

Download all attachments as: .zip

Change history (4)

Changed 11 months ago by guichunli

Bitstream file

Changed 11 months ago by guichunli

Screenshot

comment:1 Changed 11 months ago by fbossen

Looks like the code is designed to throw exceptions (and catch them) when hitting the end of a file.

In the InputByteStream constructor, there is:
istream.exceptions(std::istream::eofbit | std::istream::badbit);

comment:2 Changed 3 months ago by fbossen

  • Resolution set to wontfix
  • Status changed from new to closed

Closing this since it appears to be a feature, not a bug.

Note: See TracTickets for help on using tickets.