#237 closed defect (fixed)

N0413 – DPCM Reference Sample Filtering

Reported by: bheng Owned by:
Priority: minor Milestone: VTM-5.0
Component: VTM Version: VTM-4.2
Keywords: Cc: ksuehring, XiangLi, fbossen, jvet@…

Description

It appears that N0413 DPCM implementation intends to use unfiltered luma reference samples. For example, the following code seems to try to implement this:

IntraPrediction::useFilteredIntraRefSamples( )
{

...

#if JVET_N0413_RDPCM

if( isLuma( chType ) && pu.cu->bdpcmMode ) { return false; }

#endif

...

}

However, it appears that the above function “useFilteredIntraRefSamples” is never actually called anywhere. Therefore, the above code is never executed and has no effect.

Instead, in the following function, the DPCM mode is treated as PLANAR and the reference filtering can be enabled (or not) depending on the block size.

If this is not the intended behavior, I believe the following function should be fixed to add a DPCM condition.

IntraPrediction::initPredIntraParams( )
{

...
else if (dirMode == PLANAR_IDX) Planar intra prediction
{

m_ipaParam.refFilterFlag = puSize.width * puSize.height > 32 ? true : false;

}
...

}

Change history (1)

comment:1 Changed 21 months ago by XiangLi

  • Milestone set to VTM-5.0
  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.