#243 closed defect (duplicate)

Wrong CABAC bin type classification when RExt__DECODER_DEBUG_BIT_STATISTICS is enabled

Reported by: peterchuang Owned by:
Priority: minor Milestone: VTM-5.0
Component: VTM Version: VTM-4.2
Keywords: Cc: ksuehring, XiangLi, fbossen, jvet@…

Description

When RExtDECODER_DEBUG_BIT_STATISTICS is enabled, the decoder can collect the bin statistic of each syntax element, e.g. how may context-coded bins and how many bypass-coded bins are used for a certain syntax element.
In "CABACReader::residual_coding_subblock", the bin-type of dec_abs_level syntax is not assigned. So the bypass bins of dec_abs_level might be classified as the bypass bins of sig_coeff_flag, abs_level_gt1_flag, or abs_level_gt3_flag.
One line of code should be added as the attached patch (on top of 2a709903020e3b215ada12b0c4281141c7f83891 [2a70990])

Change history (1)

comment:1 Changed 18 months ago by XiangLi

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #244.

Note: See TracTickets for help on using tickets.