Opened 3 years ago

Closed 3 years ago

#25 closed defect (fixed)

Encoder bugs in quantization when QTBT is enabled

Reported by: XiangLi Owned by:
Priority: minor Milestone: HM-16.6-JEM-4.0
Component: JEM Version: HM-16.6-JEM-3.1
Keywords: Cc: ksuehring, XiangLi, jvet@…

Description

First, scaling list is not properly initialized for 128×128 transform. Second, error scale coefficients are not properly initialized for 2M×2N blocks when ((M+N)&0x01)≠0. Consequently, encoder sometimes makes incorrect rate-distortion decisions, which degrades overall coding performance. With the attached patch, 0.5+% luma BD-rate reduction is observed for RA, LD-B and LD-P without encoding time increase. (The issue is also reported in JVET-D0025.)

Attachments (1)

JVET-D0025_QuantFix.patch (3.9 KB) - added by XiangLi 3 years ago.

Download all attachments as: .zip

Change history (2)

Changed 3 years ago by XiangLi

comment:1 Changed 3 years ago by XiangLi

  • Milestone set to HM-16.6-JEM-4.0
  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r300

Note: See TracTickets for help on using tickets.