Opened 5 months ago

Closed 4 months ago

#319 closed defect (fixed)

IBC BV range description

Reported by: yuhan Owned by:
Priority: minor Milestone: VVC D5 v9
Component: spec Version: VVC D5 v10
Keywords: IBC Cc: ksuehring, bbross, XiangLi, fbossen, jvet@…

Description

The description of IBC BV range is not very accurate.

– The motion vector mvL shall point to a reference block that is fully contained in the same coding tree block as the current block or fully contained in a block to the left with the same height of the current coding tree block and a width equal to 128 luma samples, i.e. all of the following conditions shall be true:


The problem is the fixed number of 128. The equations list here are trying to reflect the description above.
xRefTL >> CtbLog2SizeY >= ( xCb >> CtbLog2SizeY ) + Min( 1, 7 − CtbLog2SizeY ) (8 893)

− ( 1 << ( (7 − CtbLog2SizeY ) << 1) ) )

xRefBR >> CtbLog2SizeY <= ( xCb >> CtbLog2SizeY ) (8 894)

As you can see, the width is actually defined by + Min( 1, 7 − CtbLog2SizeY )-( 1 << ( (7 − CtbLog2SizeY ) << 1) ) ), instead of 128 luma samples.

Change history (4)

comment:1 Changed 5 months ago by bbross

  • Version changed from VVC D5 v8 to VVC D5 v9

comment:2 Changed 5 months ago by bbross

  • Version changed from VVC D5 v9 to VVC D5 v10

comment:3 Changed 4 months ago by bbross

Fixed in D6 vC

comment:4 Changed 4 months ago by bbross

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in D6 vC

Note: See TracTickets for help on using tickets.