#349 closed defect (fixed)

Error in "setMergeInfo" : Merge candidate does not exist

Reported by: fbarbier Owned by:
Priority: minor Milestone: VTM-5.1
Component: VTM Version: VTM-5.0
Keywords: Cc: ksuehring, XiangLi, fbossen, jvet@…

Description

Tested with 41243806ea1dbada839d47076a60f77ef6cafd39

An error is triggered In function "setMergeInfo" in CommonLib/ContextModelling.cpp:404: Merge candidate does not exist

Please try with the following command lines to reproduce the issue:

git checkout 41243806ea1dbada839d47076a60f77ef6cafd39

cd build
cmake .. -DCMAKE_BUILD_TYPE=Debug
make -j 8
cd ..

./bin/EncoderAppStaticd --SourceWidth=56 --SourceHeight=8 --InputChromaFormat=420 --InputBitDepth=10 --Profile=next --FrameRate=60 --FramesToBeEncoded=5 --GOPSize=4 '--Frame1=B 1 5 -6.5 0.2590 0 0 1.0 0 0 0 4 4 1 5 9 13 0 0' '--Frame2=B 2 4 -6.5 0.2590 0 0 1.0 0 0 0 4 4 1 2 6 10 0 0' '--Frame3=B 3 5 -6.5 0.2590 0 0 1.0 0 0 0 4 4 1 3 7 11 0 0' '--Frame4=B 4 1  0.0 0.0    0 0 1.0 0 0 0 4 4 1 4 8 12 0 0' --FastSearch=2 --PBIntraFast=1 --LumaLevelToDeltaQPMode=0 --MaxCUWidth=12 --MaxCUHeight=4 --CTUSize=64 --MaxPartitionDepth=5 --PCMEnabledFlag=1 --SAO=1 --LoopFilterDisable=1 --ALF=1 --DisableIntraInInter=1 --DepQuant=1 --DualITree=0 --LMChroma=0 --TransformSkip=0 --MaxDeltaQP=0 --MTS=3 --IBC=1 --IMV=1 --Affine=1 --AffineType=1 --AffineAmvr=1 --MHIntra=1 --Triangle=0 --MIP=0 --SMVD=0 --SBT=1 --RDPCM=1 -i source.yuv -b /dev/null

VVCSoftware: VTM Encoder Version 5.0 [Linux][GCC 8.2.0][64 bit] [SIMD=AVX] 

TOOL CFG: IBD:0 HAD:1 RDQ:1 RDQTS:1 RDpenalty:0 LQP:0 SQP:0 ASR:0 MinSearchWindow:8 RestrictMESampling:0 FEN:0 ECU:0 FDM:1 CFM:0 ESD:0 TransformSkip:0 TransformSkipFast:0 TransformSkipLog2MaxSize:5 Slice: M=0 Tiles:1x1 MCTS:0 CIP:0 SAO:1 ALF:1 PCM:1 TransQuantBypassEnabled:0 WPP:0 WPB:0 PME:2  WaveFrontSynchro:0 WaveFrontSubstreams:1 ScalingList:0 TMVPMode:1  DQ:1  SignBitHidingFlag:0 RecalQP:0 
NEXT TOOL CFG: LFNST:0 MMVD:1 Affine:1 AffineType:1 SubPuMvp:0+0 DualITree:0 IMV:1 BIO:0 LMChroma:0 MTS: 1(intra) 1(inter) SBT:1 ISP:0 SMVD:0 CompositeLTReference:0 GBi:0 GBiFast:0 LADF:0 MHIntra:1 Triangle:0 AllowDisFracMMVD:0 AffineAmvr:1 AffineAmvrEncOpt:0 DMVR:0 MmvdDisNum:8 RDPCM:1 IBC:1 HashME:0 WrapAround:0 LoopFilterAcrossVirtualBoundaries:0 Reshape:0 MIP:0 EncDbOpt:0 
FAST TOOL CFG: LCTUFast:0 FastMrg:0 PBIntraFast:1 IMV4PelFast:1 MTSMaxCand: 3(intra) 4(inter) AMaxBT:0 E0023FastEnc:1 ContentBasedFastQtbt:0 UseNonLinearALFLuma:1 UseNonLinearALFChroma:1 NumSplitThreads:1 NumWppThreads:1+0 EnsureWppBitEqual:0 


 started @ Fri Jul  5 12:03:45 2019
POC    0 TId: 0 ( I-SLICE, QP 30 )       2184 bits [Y 35.6823 dB    U 35.9251 dB    V 35.8068 dB] [ET     2 ] [L0 ] [L1 ]
terminate called after throwing an instance of 'Exception'
  what():  
ERROR: In function "setMergeInfo" in /source/Lib/CommonLib/ContextModelling.cpp:404: Merge candidate does not exist

Attachments (1)

source.yuv (6.6 KB) - added by fbarbier 13 months ago.

Download all attachments as: .zip

Change history (3)

Changed 13 months ago by fbarbier

comment:1 Changed 13 months ago by fbarbier

The regression seems to be introduced by commit:
1666ad0ecc6cc655885108edcc46c34a4fa500b6

comment:2 Changed 13 months ago by XiangLi

  • Milestone set to VTM-5.1
  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.