Opened 2 years ago

Closed 2 years ago

#425 closed defect (fixed)

[IBC] invalid block vector for IBC - assertion failure

Reported by: fbarbier Owned by:
Priority: minor Milestone: VTM-6.0
Component: VTM Version: VTM-5.2
Keywords: Cc: ksuehring, XiangLi, fbossen, jvet@…

Description

Encoder produces bitstreams that lead to decoder crash.

Please find the following command lines to reproduce:

git checkout dbf0d93a4473820743ed6e4affcb413060763e86

cd build
cmake .. -DCMAKE_BUILD_TYPE=Debug
make -j 8
cd ..

./bin/EncoderAppStaticd --SourceWidth=128 --SourceHeight=120 --InputChromaFormat=420 --InputBitDepth=10 --Profile=next --FrameRate=60 --FramesToBeEncoded=2 --MaxBTDepth=0 --GOPSize=4 '--Frame1=B 1 5 -6.5 0.2590 0 0 1.0 0 0 0 4 4 1 5 9 13 0 0' '--Frame2=B 2 4 -6.5 0.2590 0 0 1.0 0 0 0 4 4 1 2 6 10 0 0' '--Frame3=B 3 5 -6.5 0.2590 0 0 1.0 0 0 0 4 4 1 3 7 11 0 0' '--Frame4=B 4 1  0.0 0.0    0 0 1.0 0 0 0 4 4 1 4 8 12 0 0' --FastSearch=2 --LCTUFast=1 --PBIntraFast=1 --LumaLevelToDeltaQPMode=0 --MaxCUWidth=16 --MaxCUHeight=4 --CTUSize=128 --MaxPartitionDepth=5 --PCMEnabledFlag=1 --SAO=1 --LoopFilterDisable=1 --ALF=1 --DisableIntraInInter=1 --DepQuant=0 --SignHideFlag=1 --DualITree=1 --LMChroma=0 --TransformSkip=1 --MaxDeltaQP=0 --MTS=1 --IBC=1 --IMV=1 --Affine=0 --AffineType=1 --AffineAmvr=0 --MHIntra=0 --Triangle=0 --MIP=0 --SMVD=0 --SBT=0 --RDPCM=1 -i source.yuv -b encoded.vvc
./bin/DecoderAppStaticd -b encoded.vvc -o /dev/null

Attachments (1)

source.yuv (90.0 KB) - added by fbarbier 2 years ago.

Download all attachments as: .zip

Change history (4)

Changed 2 years ago by fbarbier

comment:1 Changed 2 years ago by fbarbier

Here is the output:

VVCSoftware: VTM Decoder Version 5.2 [Linux][GCC 8.2.0][64 bit] [SIMD=AVX]
POC 0 TId: 0 ( I-SLICE, QP 30 ) [DT 0.005] [L0 ] [L1 ] [:,(unk)]
terminate called after throwing an instance of 'Exception'

what():

ERROR: In function "xDeriveCUMV" in /home/fredb/projects/vtm/source/Lib/DecoderLib/DecCu.cpp:931: invalid block vector for IBC detected

comment:2 Changed 2 years ago by XiangLi

The issue looks not related to IBC, but split inferring. Please check whether https://vcgit.hhi.fraunhofer.de/jvet/VVCSoftware_VTM/merge_requests/831 fixes the issue.

comment:3 Changed 2 years ago by ksuehring

  • Milestone set to VTM-6.0
  • Resolution set to fixed
  • Status changed from new to closed

Seems to be fixed.

Note: See TracTickets for help on using tickets.