Opened 3 months ago

Closed 3 months ago

#471 closed defect (wontfix)

JVET-O0050 - Context derivation for mode_constraint_flag

Reported by: bheng Owned by:
Priority: minor Milestone:
Component: spec Version: VVC D6 vE
Keywords: Cc: ksuehring, bbross, XiangLi, fbossen, jvet@…

Description

For the purposes of mode constraints (JVET-O0050), IBC is treated as intra prediction. Specifically, CUs with MODE_TYPE_INTRA can use either MODE_INTRA or MODE_IBC prediction.

With that in mind, for context derivation why is only MODE_INTRA considered and MODE_IBC is treated as inter?

Specifically, the following row from Table 9-18.

mode_constraint_flag
CuPredMode[ xNbL ][ yNbL ] = = MODE_INTRA
CuPredMode[ xNbA ][ yNbA ] = = MODE_INTRA

Should these conditions be (MODE_INTRA | | MODE_IBC) instead?

Change history (2)

comment:1 Changed 3 months ago by zhaoyin

The intention of using MODE_INTRA only in the context modeling was to use the same context derivation method as pred_mode_flag, instead of introducing a new way. There might be minor coding gain when IBC is on, if checking both MODE_INTRA and MODE_IBC. This flag is signaled in P/B slices, and in this case, the probablity for small blocks to choose IBC mode might be low.

comment:2 Changed 3 months ago by bheng

  • Resolution set to wontfix
  • Status changed from new to closed

Thanks for the explanation.

In my opinion, it seems like a very minor cost to align the context derivation with the actual usage of that flag. It's just an OR of already existing conditions for pred_mode_flag and pred_mode_ibc_flag.

In any case, if the current behavior is what was intended in the JVET-O0050 proposal, then I'll close the bug report.

Note: See TracTickets for help on using tickets.