#480 closed defect (duplicate)

Inference rule for pred_mode_ibc_flag correction

Reported by: axink Owned by:
Priority: minor Milestone:
Component: spec Version: VVC D6 vE
Keywords: Cc: ksuehring, bbross, XiangLi, fbossen, jvet@…

Description

IBC block size is limited to be <=64 at each side. When block size is larger than that, pred_mode_ibc_flag is not signaled and should be inferred as 0.

In the current spec, we have:

When pred_mode_ibc_flag is not present, it is inferred as follows:
...
– Otherwise, if both cbWidth and cbHeight are equal to 128, pred_mode_ibc_flag is inferred to be equal to 0.

This should be corrected as:

...
– Otherwise, if either cbWidth is equal to 128 or cbHeight is equal to 128, pred_mode_ibc_flag is inferred to be equal to 0.

Change history (3)

comment:1 Changed 15 months ago by fbarbier

Duplicate from 473

comment:2 Changed 15 months ago by axink

Just realize that. Thanks for pointing out.

comment:3 Changed 15 months ago by axink

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #473.

Note: See TracTickets for help on using tickets.