Opened 5 years ago

Closed 5 years ago

#482 closed defect (fixed)

Renaming of pps_max_num_merge_cand_minus_max_num_triangle_cand_minus1

Reported by: martin.m.pettersson Owned by:
Priority: minor Milestone:
Component: spec Version: VVC D6 vE
Keywords: Cc: ksuehring, bbross, XiangLi, fbossen, jvet@…


pps_max_num_merge_cand_minus_max_num_triangle_cand_minus1 should be renamed pps_max_num_merge_cand_minus_max_num_triangle_cand_plus1 and

pps_max_num_merge_cand_minus_max_num_triangle_cand_minus1 + 1

should be replaced by

pps_max_num_merge_cand_minus_max_num_triangle_cand_plus1 - 1

Change history (5)

comment:1 Changed 5 years ago by yk

Martin, could you please explain why these changes should be made (since it is not obvious to me)? If this is not a bug but an improvement, it'd be better that you submit a proposal for it.

comment:2 Changed 5 years ago by martin.m.pettersson

Hi Ye-Kui,

I believe it is a typo in the VVC draft.

max_num_merge_cand_minus_max_num_triangle_cand is one of the eight parameters that can be signaled either in PPS or in the slice header, according to the adoption of JVET-O0238. The mechanism works as follows. If the parameter pps_X signaled in PPS is equal to 0, then the value for the parameter X is explicitly signaled in the slice header, otherwise (if pps_X is larger than 0), the value for X is set to pps_X minus 1. This enables X to have the value 0.

There were some editorial name changes made for the VVC draft, compared to the adopted JVET-O0238, including renaming the pps_or_slice_flag to constant_slice_header_params_enabled_flag and suffixing the eight parameters in PPS with "_idc" for the flags and "_plus1" for the ue(v) values.

I think the renaming of the parameters compared to what was in JVET-O0238 are very good, but it seems there was a typo for one of the parameters, pps_max_num_merge_cand_minus_max_num_triangle_cand_minus1. This parameter uses the same mechanism as the other seven parameters and should also have the suffix "_plus1".

The other seven parameters are correct and according to JVET-O0238, it is only this one that got a plus instead of a minus in the VVC draft.

comment:3 follow-up: Changed 5 years ago by bbross

I agree with Martin that the plus1 suffix is what we intended to do.
How is VTM signalling it, as plus1 or minus1?

comment:4 in reply to: ↑ 3 Changed 5 years ago by martin.m.pettersson

Replying to bbross:

I agree with Martin that the plus1 suffix is what we intended to do.
How is VTM signalling it, as plus1 or minus1?

It is implemented with the plus1 suffix in VTM, just like the other ue(v) parameters.

comment:5 Changed 5 years ago by bbross

  • Resolution set to fixed
  • Status changed from new to closed

Thanks for conforming, it is fixed in a document we are preparing to be submitted as an editorial input
to the 16th JVET meeting.

Furthermore, I resolved the syntax element name subsetting issues notes in Ye-Kuis notes by addign a slice_ prefix to the following syntax elements:

  • slice_six_minus_max_num_merge_cand
  • slice_five_minus_max_num_subblock_merge_cand
  • slice_max_num_merge_cand_minus_max_num_triangle_cand
  • slice_dep_quant_enabled_flag

Otherwise, their name would be fully contained in the corresponding pps syntax element name.

Note: See TracTickets for help on using tickets.