Opened 5 months ago

Closed 2 months ago

#495 closed defect (fixed)

Mismatch between software and text on BDOF

Reported by: Yusuke_Kato Owned by:
Priority: minor Milestone:
Component: spec Version: VVC D6 vE
Keywords: Cc: ksuehring, bbross, XiangLi, fbossen, jvet@…

Description

Suggest to align Spec to SW

8.5.6.5 Bi-directional optical flow prediction process
vx = sGx2 > 0 ? Clip3( −mvRefineThres, mvRefineThres, −( sGxdI << 3 ) >> Floor( Log2( sGx2 ) ) ) : 0 (8-817)
...
bdofOffset = ( vx * ( gradientHL0[ x + 1 ][ y + 1 ] − gradientHL1[ x + 1 ][ y + 1 ] ) ) >> 1 + ( vy * (gradientVL0[ x + 1 ][ y + 1 ] − gradientVL1[ x + 1 ][ y + 1 ] ) ) >> 1 (8-819)

shall be corrected to:

8.5.6.5 Bi-directional optical flow prediction process
vx = sGx2 > 0 ? Clip3( −mvRefineThres, mvRefineThres, ( sGxdI << 3 ) >> Floor( Log2( sGx2 ) ) ) : 0 (8-817)
...
bdofOffset = ( vx * ( gradientHL0[ x + 1 ][ y + 1 ] − gradientHL1[ x + 1 ][ y + 1 ] ) + vy * (gradientVL0[ x + 1 ][ y + 1 ] − gradientVL1[ x + 1 ][ y + 1 ] ) + 1) >> 1 (8-819)

Change history (3)

comment:1 Changed 4 months ago by bbross

Any opinions on this?
Is this a confirmed mismatch?
Does it make sense to align spec to VTM?

comment:2 Changed 4 months ago by abe.kiyo

I am one of the reporter of this ticket.
This mismatch was pointed out by Ching-Yeh (MediaTek), and we (Panasonic) submitted after the double check.
We believe the first item is not debatable. On the other hand, the second item has the room for discussion about whether to align spec or VTM. We suggest to align it to VTM as registered in this ticket, since the similar processing in PROF is described by this way.

Best regards,
Kiyofumi Abe

comment:3 Changed 2 months ago by bbross

  • Resolution set to fixed
  • Status changed from new to closed

Thanks for confirming. Fixed the first item for JVET-P2001-vC as suggested to align spec to VTM.
For the second item, the derivation of bdofOffset change and does not right shift anymore so this should be OK in the current draft.

Note: See TracTickets for help on using tickets.