Opened 8 weeks ago

Closed 8 weeks ago

#547 closed defect (duplicate)

Uncorrect pruning in derivation of spatial merging candidate

Reported by: antoine.robert Owned by:
Priority: minor Milestone:
Component: spec Version: VVC D6 vE
Keywords: Cc: ksuehring, bbross, XiangLi, fbossen, jvet@…

Description

In 8.5.2.3 Derivation process for spatial merging candidates, the pruning is:

  • candidate B1 is pruned with A1
  • candidate B0 is pruned with B1, A1
  • candidate A0 is pruned with A1, B1, B0
  • candidate B2 is pruned with A1, B1, B0, A0

But JVET-L0093 reduces it to:

  • candidate B1 is pruned with A1
  • candidate B0 is pruned with B1, A1
  • candidate A0 is pruned with A1, B1, B0
  • candidate B2 is pruned with A1, B1, B0, A0

The corresponding lines of the spec should be removed as, for example with candidate A0:


The variables availableFlagA0, refIdxLXA0, predFlagLXA0 and mvLXA0 are derived as follows:

If one or more of the following conditions are true, availableFlagA0 is set equal to 0, both components of mvLXA0 are set equal to 0, refIdxLXA0 is set equal to −1 and predFlagLXA0 is set equal to 0, with X being 0 or 1, and bcwIdxA0 is set equal to 0:

availableA0 is equal to FALSE.
availableA1 is equal to TRUE and the luma locations (xNbA1, yNbA1) and (xNbA0, yNbA0) have the same motion vectors and the same reference indices.
availableB1 is equal to TRUE, the luma locations (xNbB1, yNbB1) and (xNbA0, yNbA0) have the same motion vectors and the same reference indices and MergeTriangleFlag[xCb][yCb] is equal to 1.
availableB0 is equal to TRUE, the luma locations (xNbB0, yNbB0) and (xNbA0, yNbA0) have the same motion vectors and the same reference indices and MergeTriangleFlag[xCb][yCb] is equal to 1.

Change history (2)

comment:1 Changed 8 weeks ago by LiZhang

same as ticket #344. It seems the fixes haven't been integrated to VVC D6 vE.

comment:2 Changed 8 weeks ago by bbross

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #344.

Note: See TracTickets for help on using tickets.