Opened 4 months ago

Closed 6 weeks ago

#584 closed defect (fixed)

Missing constraints when resolution is not multiple of CtbSizeY

Reported by: forayr Owned by:
Priority: minor Milestone:
Component: spec Version: VVC D7 vE
Keywords: Cc: ksuehring, XiangLi, fbossen, jvet@…

Description

When the resolution is not multiple of CtbSizeY, the values of MinQtSize and MaxMTTHierarchyDepth might not allowed the coding_tree to be split enough to code the incomplete Ctb.
This leads in the specification to a case where split_cu_flag is inferred to 1, whereas all allowSplitFlag (Bt,Tt,Qt) are equal to 0.

Constraints should be added on the partition constraints, and/or on the picture width/height.

For example, the following case should not be allowed:

  • MinCbSizeY = 4
  • MinQtSize = 32
  • MaxMTTHierarchyDepth = 0
  • pic_width_in_luma_samples = 8
  • pic_height_in_luma_samples = 8

Change history (6)

comment:1 Changed 4 months ago by ksuehring

  • Component changed from VTM to spec

Changing component to spec, since this seems to be a specification issue, not software.

comment:2 Changed 4 months ago by bbross

  • Version changed from VVC D6 vE to VVC D7 vC

comment:3 Changed 4 months ago by bbross

Thanks for pointing this out.
Can anyone familiar with the MTT provide the missing constraints?

comment:4 Changed 4 months ago by bbross

  • Version changed from VVC D7 vC to VVC D7 vD

comment:5 Changed 4 months ago by bbross

  • Version changed from VVC D7 vD to VVC D7 vE

comment:6 Changed 6 weeks ago by XiangLi

  • Resolution set to fixed
  • Status changed from new to closed

The issue is resolved in VVC D8 (JVET-Q2001-v3) with the adoption of JVET-Q0330.

Note: See TracTickets for help on using tickets.