Opened 9 months ago

Closed 9 months ago

#714 closed defect (duplicate)

Problem with lossless

Reported by: Jamaika Owned by:
Priority: minor Milestone:
Component: VTM Version: VTM-7.0
Keywords: Cc: ksuehring, XiangLi, fbossen, jvet@…

Description

VVCSoftware: VTM Encoder Version 7.0 [Windows][GCC 10.0.0][64 bit] [SIMD=NONE]
VVCSoftware: HDRTools Version 0.19.1
VVCSoftware: libgomp / pthreads 32bit : 1.0 / 3.0 [SPLIT_PARALLEL (6 jobs)][WPP_PARALLEL]

Input real format & framerate : 640x360 25Hz
Input pixel format & bitdepth : rgb24
Input color space / primaries : RGB / Undef
Input color range : full
Frame/Field : Frame based coding
Frame index : 0 - 0 (1 frames)
Profile : next
Cost function: : Lossless coding with fixed QP of 0
TOOL CFG: IBD:0 HAD:0 RDQ:1 RDQTS:1 RDpenalty:0 LQP:0 SQP:0 ASR:0 MinSearchWindow:8 RestrictMESampling:0 FEN:0 ECU:0 FDM:1 CFM:0 ESD:0 TransformSkip:1 TransformSkipFast:1 TransformSkipLog2MaxSize:5 ChromaTS:1 BDPCM:0 Slice: M=0 Tiles:1x1 MCTS:0 CIP:0 SAO:1 ALF:1 TransQuantBypassEnabled:0 WPP:0 WPB:0 PME:2 WaveFrontSynchro:0 WaveFrontSubstreams:1 ScalingList:0 TMVPMode:1 DQ:1 SignBitHidingFlag:0 RecalQP:0
NEXT TOOL CFG: LFNST:1 MMVD:1 Affine:1 AffineType:1 PROF:1 SubPuMvp:1+0 DualITree:1 IMV:1 BIO:1 LMChroma:1 MTS: 1(intra) 0(inter) SBT:1 ISP:1 SMVD:1 CompositeLTReference:0 GBi:1 GBiFast:1 LADF:0 MHIntra:1 Triangle:1 AllowDisFracMMVD:1 AffineAmvr:1 AffineAmvrEncOpt:0 DMVR:1 MmvdDisNum:8 JointCbCr:1 PLT:0 IBC:0 HashME:0 WrapAround:0 LoopFilterAcrossVirtualBoundaries:0 Reshape:0 MIP:1 EncDbOpt:0
FAST TOOL CFG: LCTUFast:1 FastMrg:1 PBIntraFast:1 IMV4PelFast:1 MTSMaxCand: 4(intra) 4(inter) ISPFast:0 FastLFNST:0 AMaxBT:1 E0023FastEnc:1 ContentBasedFastQtbt:0 UseNonLinearAlfLuma:1 UseNonLinearAlfChroma:1 MaxNumAlfAlternativesChroma:8 FastMIP:0 FastLocalDualTree:1 NumSplitThreads:1 NumWppThreads:1+0 EnsureWppBitEqual:1 RPR:0 TemporalFilter:0

started @ Sun Nov 17 23:03:45 2019

ERROR: In function "xCompressCU" in EncCu.cpp:926: Should always get a result in serial case

Change history (2)

comment:1 Changed 9 months ago by tung.nguyen

I see all the coding tools enabled that should be disabled for lossless.
Have you used the lossless.cfg provided with the VTM7?

comment:2 Changed 9 months ago by Jamaika

  • Resolution set to duplicate
  • Status changed from new to closed

Sorry my mistake

Note: See TracTickets for help on using tickets.