Opened 3 years ago

Closed 3 years ago

#74 closed defect (fixed)

VTM-2.0rc1 decoder crash under certain configuration

Reported by: hanhuang Owned by: XiangLi
Priority: minor Milestone: BMS-2.0
Component: VTM Version: BMS-2.0rc1
Keywords: Cc: ksuehring, XiangLi, fbossen, jvet@…

Description

Test condition is random access. Changes to the default settings are: CTUSize = 64, ALF = 0, MTT = 0
Testing sequence: BasketballDrive, 2 frames, QP=32

Decoder crash infor:
VVCSoftware: VTM Decoder Version 2.0rc1 [Windows][VS 1913][64 bit] [SIMD=AVX2]

ERROR: In function "DecSlice::decompressSlice" in c:\users\hhan1\documents\jvet\software\vvcsoftware_vtm-vtm-2.0rc1\source\lib\decoderlib\decslice.cpp:269: Last CTU of slice segment not signalled as such

Attachments (1)

encoder_randomaccess_vtm.cfg (11.4 KB) - added by hanhuang 3 years ago.

Download all attachments as: .zip

Change history (3)

Changed 3 years ago by hanhuang

comment:1 Changed 3 years ago by XiangLi

  • Owner set to XiangLi
  • Status changed from new to assigned

Thanks for the report. I just duplicated the issue. I am checking it.

comment:2 Changed 3 years ago by XiangLi

  • Milestone set to BMS-2.0
  • Resolution set to fixed
  • Status changed from assigned to closed
  • Version set to BMS-2.0rc1

The issue is related dual tree force split. It has been fixed in merge request !64,
https://vcgit.hhi.fraunhofer.de/jvet/VVCSoftware_BMS/merge_requests/64

Note: See TracTickets for help on using tickets.