Opened 7 months ago

Closed 6 months ago

#743 closed defect (invalid)

Line 1539 code of DepQuant.cpp in VTM master source seem to be error

Reported by: annci Owned by:
Priority: minor Milestone:
Component: VTM Version:
Keywords: Cc: ksuehring, XiangLi, fbossen, jvet@…

Description

Line 1539 code of DepQuant.cpp in VTM master source seem to be error.
The code of Line 1539:
int64_t minPathCost = 0;

Change history (2)

comment:1 Changed 7 months ago by schwarz

Why do you think it is wrong?

It looks correct to me. Cost equal to 0 refers to the case that all transform coefficient levels are equal to 0. The costs calculated in the encoding process are cost differences relative to this default case. Hence, if all costs of the trellis paths are greater than 0, the default (all levels equal to 0) is chosen, in which case nothing needs to be modified.

comment:2 Changed 6 months ago by ksuehring

  • Resolution set to invalid
  • Status changed from new to closed

I think we can't do much here unless we have more information. Thus I'm closing the report.

If you still think there is a problem, please re-open and state why you think the problem is there.

Note: See TracTickets for help on using tickets.