Opened 4 years ago

Closed 4 years ago

#783 closed defect (fixed)

RPR - Interpolation filters for chroma affine blocks.

Reported by: bheng Owned by:
Priority: minor Milestone:
Component: spec Version: VVC D7 vE
Keywords: Cc: ksuehring, bbross, XiangLi, fbossen, jvet@…

Description

There appears to be a mismatch between the spec and software for the RPR interpolation filter selection in affine mode.

The software disables the RPR-specific filters whenever affine is enabled (for both luma and chroma). Specifically, filterIndex below is always "2" when called for affine prediction.

if( filterIndex == 0 )
{

if( scalingRatio.first > rprThreshold2 )
{

xFilter = 4;

}
else if( scalingRatio.first > rprThreshold1 )
{

xFilter = 3;

}

if( scalingRatio.second > rprThreshold2 )
{

yFilter = 4;

}
else if( scalingRatio.second > rprThreshold1 )
{

yFilter = 3;

}

}

The draft text does disable the RPR filters for luma affine mode (always uses the 6-tap filter). However, in Section 8.5.6.3.4, the chroma filter selection process does not appear to consider affine mode at all, so the RPR interpolation filters could be used.

I'm not sure what the intended behavior is for RPR filters in chroma affine mode, but either the spec or software should be updated so that the two match.

Change history (2)

comment:1 Changed 4 years ago by jlchen

With JVET-Q0517 adoption, the RPR filters is also used in chroma affine mode. The issue will be automatically addressed.

comment:2 Changed 4 years ago by bbross

  • Resolution set to fixed
  • Status changed from new to closed

So I guess this should be fixed by the VTM integration of JVET-Q0517.
Spec text of JVET-Q0517 does not change chroma interpolation.

Note: See TracTickets for help on using tickets.