Opened 7 months ago

Closed 7 months ago

#811 closed defect (fixed)

missing affine MVD prediction in spec.

Reported by: hanhuang Owned by:
Priority: minor Milestone:
Component: spec Version: VVC D7 vE
Keywords: Cc: vzakharc, yuwenhe, jvet@…

Description

The affine MVD prediction (per adoption of CE4-1.3.b in JVET-K0337), i.e. predict the MVD of CPMV1 and CPMV2 from MVD of CPMV0, is missing in current spec.

The relative meeting note is quoted in the bellow:
"JVET-K0337: Affine MC coding and models (4.1.3a, affine MVP list construction, and 4.1.3b, MV difference coding, and 4.1.3c, 4/6 parameter model, no slice level switch)."

suggested fix in 8.5.5.1 of current spec.:

3.The variable mvdCpLX[ cpIdx ] with cpIdx equals to 0 is derived as follows:

mvdCpLX[ cpIdx ][ 0 ] = MvdCpLX[ xCb ][ yCb ][ cpIdx ][ 0 ] (671)
mvdCpLX[ cpIdx ][ 1 ] = MvdCpLX[ xCb ][ yCb ][ cpIdx ][ 1 ] (672)

The variable mvdCpLX[ cpIdx ] with cpIdx ranging from 1 to numCpMv − 1, is derived as follows:

mvdCpLX[ cpIdx ][ 0 ] = MvdCpLX[ xCb ][ yCb ][ cpIdx ][ 0 ] + MvdCpLX[ xCb ][ yCb ][ 0 ][ 0 ]
mvdCpLX[ cpIdx ][ 1 ] = MvdCpLX[ xCb ][ yCb ][ cpIdx ][ 1 ] + MvdCpLX[ xCb ][ yCb ][ 0 ][ 1 ]

Change history (3)

comment:1 Changed 7 months ago by hanhuang

  • Component changed from 360Lib to spec
  • Milestone VVC D7 vC deleted

comment:2 Changed 7 months ago by jlchen

The issue is valid and will be fixed.

comment:3 Changed 7 months ago by bbross

  • Resolution set to fixed
  • Status changed from new to closed

Thanks for reporting!

This has been fixed in JVET-Q2001-v7.

Note: See TracTickets for help on using tickets.