#856 closed defect (fixed)

[JVET_Q0110_Q0785_CHROMA_BDPCM_420] crash on monochrome streams

Reported by: fbarbier Owned by:
Priority: minor Milestone: VTM-8.0
Component: VTM Version:
Keywords: Cc: ksuehring, XiangLi, fbossen, jvet@…

Description

In CabacReader.cpp,
function call bdpcm_mode(cu, ComponentID(CHANNEL_TYPE_CHROMA)) segfaults when chroma_format_idc is equal to 0.

Change history (2)

comment:1 Changed 20 months ago by analci

I was not able to reproduce this issue in the latest commit.

JVET_Q0438 which fixes monochrome issues appears to be ported after JVET_Q0785.
Monochrome fix in JVET_Q0438 for chroma BDPCM appears to be incorrect on top of JVET_Q0785.
I submitted a merge request (!1325) which should potentially solve this issue.

comment:2 Changed 20 months ago by ksuehring

  • Milestone set to VTM-8.0
  • Resolution set to fixed
  • Status changed from new to closed

The MR was merged

Note: See TracTickets for help on using tickets.