#864 closed defect (fixed)

CHECK triggered in debug mode at the decoder in InputBitstream::read

Reported by: deluxan Owned by:
Priority: minor Milestone: VTM-8.0
Component: VTM Version:
Keywords: Cc: vzakharc, yuwenhe, jvet@…

Description

The exception is triggered in

CHECK(m_fifo_idx + num_bytes_to_load >= m_fifo.size(), "Exceeded FIFO size");

within the function InputBitstream::read in debug mode.

The bitstream was generated with BlowingBubbles, QP 37, 1 frame and AI.

Change history (6)

comment:1 Changed 20 months ago by deluxan

  • Component changed from 360Lib to VTM

comment:2 Changed 20 months ago by fbossen

Is this occurring after the fix for #863?

comment:3 Changed 20 months ago by deluxan

Unfortunately, no.
I checked in the master version a3406e2ea28189031c86dbb085b293abe1558720 (the one right after MR !1330 was merged) and the problem is still there.

In the newest master there are new problems, but I think MR !1331 is already addressing them.

comment:4 Changed 20 months ago by deluxan

I meant, unfortunately the problem IS still occurring.

comment:6 Changed 20 months ago by ksuehring

  • Milestone set to VTM-8.0
  • Resolution set to fixed
  • Status changed from new to closed

The MR was merged.

Note: See TracTickets for help on using tickets.