#870 closed defect (fixed)

Decoder crash when using MaxMTTHierarchyDepth 0

Reported by: tpoirier Owned by:
Priority: minor Milestone:
Component: VTM Version: VTM-7.0
Keywords: Cc: ksuehring, XiangLi, fbossen, jvet@…

Description

The VTM-7.0 decoder (and also current master) crashes when encoding using MaxMTTHierarchyDepth equal to 0.

This is caused by the Adaptive maximal BT-size (AMaxBT) algorithm that update pic_log2_diff_max_bt_min_qt_inter_slice even if max_mtt_hierarchy_depth_inter_slice is equal to 0. (thus pic_log2_diff_max_bt_min_qt_inter_slice is not coded and still use default value of MinQTSize at the decoder).

The crash occurs at picture boundary when MaxBTSize is used.

The issue can be reproduced using the attached config file.

Attachments (1)

encoder_randomaccess_vtm.cfg (13.3 KB) - added by tpoirier 20 months ago.

Download all attachments as: .zip

Change history (2)

Changed 20 months ago by tpoirier

comment:1 Changed 20 months ago by tpoirier

  • Resolution set to fixed
  • Status changed from new to closed

Seems to be resolved by MR !1291

Note: See TracTickets for help on using tickets.