Opened 9 months ago

Closed 9 months ago

#872 closed defect (duplicate)

Mismatch between spec and VTM in colour space conversion

Reported by: yhchao Owned by:
Priority: minor Milestone: VVC D7 vC
Component: spec Version: VVC D8 vB
Keywords: Cc: ksuehring, bbross, XiangLi, fbossen, jvet@…

Description

There seems to be a mismatch between the spec and VTM software regarding colour space conversion.

In spec, equation (1226), rCr[ x ][ y ] is calculated as:
rCr[ x ][ y ] += rCr[ x ][ y ]

while in VTM it is calculated as:
rCr[ x ][ y ] += rCb[ x ][ y ]

From the original proposal JVET-Q0510 and what was adopted in the meeting, the spec should be corrected (software is correct). There is a mistake in the combined spec JVET-Q0820.

Change history (1)

comment:1 Changed 9 months ago by jonathang

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #839.
This seems to be a more thorough analysis of the same bug reported in #839

Note: See TracTickets for help on using tickets.