Opened 16 months ago

Closed 16 months ago

Last modified 16 months ago

#1109 closed defect (fixed)

Constraints failing in multi-layer coding (related to JVET-P0978)

Reported by: ksuehring Owned by:
Priority: minor Milestone:
Component: VTM Version: VTM-9.0
Keywords: Cc: ksuehring, XiangLi, fbossen, jvet@…

Description

After disabling JVET-R0099 (see #1108) the decoder fails to decode a stream generated with the example two_layers.cfg layer config file with the error message:

"Trailing picture detected that violate the rule that no active entry in RefPicList[] shall precede the associated IRAP picture in output order or decoding order"

According to git blame the check was added with:

JVET-P0978 Adding RPL related bitstream constraints

Encoder command line used:

EncoderApp -c ../cfg/encoder_randomaccess_vtm.cfg -q 50 -c ../cfg/multi-layer/two_layers.cfg -l0 -c ../cfg/per-sequence/RaceHorses.cfg -l1 -c ../cfg/per-sequence/RaceHorsesC.cfg -ipp ../../../../svn/origCfP/ -f 17 --SEIDecodedPictureHash=1

Change history (3)

comment:1 Changed 16 months ago by ksuehring

I just found that this was reported before by Vadim in #1042. That ticket also refers to

Please see the comments in MR1430.

https://vcgit.hhi.fraunhofer.de/jvet/VVCSoftware_VTM/-/merge_requests/1430

comment:2 Changed 16 months ago by ksuehring

  • Resolution set to fixed
  • Status changed from new to closed

The MR was merged

comment:3 Changed 16 months ago by ksuehring

Ticket #1042 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.