Opened 10 months ago

Closed 10 months ago

Last modified 10 months ago

#180 closed defect (fixed)

Encoder crash when using MaxDeltaQP

Reported by: delagrangep Owned by:
Priority: minor Milestone:
Component: VTM Version: VTM-3.0
Keywords: Cc: ksuehring, XiangLi, fbossen, jvet@…

Description

Tested in VTM-3.2 with -d 1 -dqd 2 encoding parameters.

CHECK(encTestmode.type != ETM_POST_DONT_SPLIT,...) fails in EncModeCtrl.cpp:1545 because encTestmode.type is ETM_RECO_CACHED

VTM4-rc1 also crashes in a different manner.

Problem blocking for validation of JVET-M0113/M0188

Attachments (1)

FIX_ISSUE_91.patch (2.0 KB) - added by adamjw 10 months ago.

Download all attachments as: .zip

Change history (4)

Changed 10 months ago by adamjw

comment:1 Changed 10 months ago by adamjw

Please find the attached patch. This is a partial duplicate of the issue #91.

I will create an appropriate fix for the current VTM-4.0-rc1.

comment:2 Changed 10 months ago by fbossen

  • Resolution set to fixed
  • Status changed from new to closed

comment:3 Changed 10 months ago by ksuehring

Ticket #91 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.