Opened 4 months ago

Closed 3 months ago

#427 closed defect (fixed)

Encoder crash for 4:4:4 for commit 16c83093

Reported by: Kenneth Owned by:
Priority: critical Milestone: VTM-6.0
Component: VTM Version:
Keywords: Cc: ksuehring, XiangLi, fbossen, jvet@…

Description (last modified by ksuehring)

I got encoder crash when I run a 4:4:4 sequence at QP 37. Perhaps already in 9d020f93?

VVCSoftware: VTM Encoder Version 5.2 [Linux][GCC 6.2.0][64 bit] [SIMD=AVX2]
 
TOOL CFG: IBD:0 HAD:1 RDQ:1 RDQTS:1 RDpenalty:0 LQP:0 SQP:0 ASR:1 MinSearchWindow:96 RestrictMESampling:0 FEN:1 ECU:0 FDM:1 CFM:0 ESD:0 TransformSkip:1 TransformSkipFast:1 TransformSkipLog2MaxSize:5 BDPCM:0 Slice: M=0 Tiles:1x1 MCTS:0 CI
P:0 SAO:1 ALF:1 PCM:0 TransQuantBypassEnabled:0 WPP:0 WPB:0 PME:2  WaveFrontSynchro:0 WaveFrontSubstreams:1 ScalingList:0 TMVPMode:1  DQ:1  SignBitHidingFlag:0 RecalQP:0
NEXT TOOL CFG: LFNST:1 MMVD:1 Affine:1 AffineType:1 PROF:1 SubPuMvp:1+0 DualITree:1 IMV:1 BIO:1 LMChroma:1 MTS: 1(intra) 0(inter) SBT:1 ISP:1 SMVD:1 CompositeLTReference:0 GBi:1 GBiFast:1 LADF:0 MHIntra:1 Triangle:1 AllowDisFracMMVD:1 Af
fineAmvr:1 AffineAmvrEncOpt:1 DMVR:1 MmvdDisNum:6 RDPCM:0 IBC:0 HashME:0 WrapAround:0 LoopFilterAcrossVirtualBoundaries:0 Reshape:1 (Signal:SDR Opt:0) MIP:1 EncDbOpt:0
FAST TOOL CFG: LCTUFast:1 FastMrg:1 PBIntraFast:1 IMV4PelFast:1 MTSMaxCand: 3(intra) 4(inter) ISPFast:1 FastLFNST:0 AMaxBT:1 E0023FastEnc:1 ContentBasedFastQtbt:0 UseNonLinearAlfLuma:1 UseNonLinearAlfChroma:1 MaxNumAlfAlternativesChroma:
8 FastMIP:0 NumSplitThreads:1 NumWppThreads:1+0 EnsureWppBitEqual:0
 
ERROR: In function "derivedChromaQPMappingTables" in /proj/video_data3/videosim/eplkan/VTM/VTM6/DMVR_DB/VVCSoftware_VTM_16c8309/source/Lib/CommonLib/Slice.cpp:1541: qpInVal out of Range

Change history (6)

comment:1 Changed 3 months ago by Kenneth

No crash after Franks fix in MR 802 that I just tested.

comment:2 Changed 3 months ago by ksuehring

It seems, 4:2:2 is also affected. This was reported as comment in GitLab on commit 9d020f93:

ERROR: In function "derivedChromaQPMappingTables" in Slice.cpp:1541: qpInVal out of range
EncoderApp.exe --SummaryVerboseness -c "encoder_randomaccess_vtm.cfg" --InputFile=111.yuv --BitstreamFile=video_2.vvc --SourceWidth=3840 --SourceHeight=2160 --FrameRate=25.000 --InputBitDepth=10 --InternalBitDepth=10 --OutputBitDepth=10 --MSBExtendedBitDepth=10 --InputChromaFormat=422 --ChromaFormatIDC=422 --MatrixCoefficients=9 --ConformanceWindowMode=1 --FramesToBeEncoded=100 --AspectRatioInfoPresent=1 --VideoSignalTypePresent=1 --ChromaLocInfoPresent=1 --VideoFullRange=1 --UseIdentityTableForNon420Chroma=1 --SameCQPTablesForAllChroma=0
MaxCUWidth : 16 # Maximum coding unit width in pixel
MaxCUHeight : 16 # Maximum coding unit height in pixel
CTUSize : 32
LMCSEnable : 1 # LMCS: 0: disable, 1:enable
LMCSSignalType : 1 # Input signal type: 0:SDR, 1:HDR-PQ, 2:HDR-HLG

comment:3 Changed 3 months ago by ksuehring

MR 802 is only a config file change. We shouldn't have the software crashing, if these tables are not explicitly configured.

comment:4 Changed 3 months ago by ksuehring

  • Description modified (diff)

comment:5 Changed 3 months ago by Kenneth

I also tried with following config:
CbQpOffset : 1 #0
CrQpOffset : 1 #0
#SameCQPTablesForAllChroma : 1
#QpInValCb : 32 44
#QpOutValCb : 32 41

and it did not crash either.

I suppose it was fixed in some other MR perhaps by Adarsh fix-426.

comment:6 Changed 3 months ago by ksuehring

  • Resolution set to fixed
  • Status changed from new to closed

Ah, I just found MR 800, which fixes the initialization. Thanks for testing.

Note: See TracTickets for help on using tickets.