Opened 4 months ago

Closed 4 weeks ago

#429 closed defect (fixed)

Mismatch with spec on allow binary/ternary split process

Reported by: forayr Owned by:
Priority: minor Milestone:
Component: spec Version: VVC D6 vE
Keywords: Cc: ksuehring, XiangLi, fbossen, jvet@…

Description

In the specification, this processes use MaxBtSizeY, which is now variable. Whereas in the function canSplit in the VTM, the constant MAX_TB_SIZEY is used, instead of the variable value present in the sps.

Change history (6)

comment:2 Changed 4 months ago by adamjw

As far as I remember, this constraint is not really directly connected to the actual allowed MaxTbSize, but rather the VPDU size (which is fixed as 64, or MAX_TB_SIZEY). So I think the software actually represents the intended behavior and this should be fixed in the spec to match 64.
The canSplit function for TU_MAX_TR_SPLIT correctly respects the now variable maximal transform size, so if a block is larger than the maximal allowed transform size, it would be sub-split into smaller TUs. There is no reason to restrict BT/TT splits depending on maximal allowed transform size.

Last edited 4 months ago by adamjw (previous) (diff)

comment:3 follow-up: Changed 4 months ago by bbross

  • Version changed from VTM-5.2 to VVC D6 vE

Changing the ticket to spec since the spec should be changed as follows:

In "6.4.2 Allowed binary split process", replace "MaxTbSizeY" with the VPDU size 64.

comment:4 Changed 4 months ago by forayr

  • Component changed from VTM to spec

comment:5 in reply to: ↑ 3 Changed 4 months ago by adamjw

Replying to bbross:

Changing the ticket to spec since the spec should be changed as follows:

In "6.4.2 Allowed binary split process", replace "MaxTbSizeY" with the VPDU size 64.

The same should be done "6.4.3 Allowed ternary split process"

comment:6 Changed 4 weeks ago by bbross

  • Resolution set to fixed
  • Status changed from new to closed

This will be fixed JVET-P2001-vC.

Note: See TracTickets for help on using tickets.