Opened 3 weeks ago

Closed 3 weeks ago

#595 closed defect (duplicate)

Possible unclarity for the half sample interpolation filter index hpelIfIdx of some merge candidates

Reported by: vdrugeon Owned by:
Priority: minor Milestone:
Component: spec Version:
Keywords: Cc: ksuehring, bbross, XiangLi, fbossen, jvet@…

Description

As far as I understand from the specification text in 8.5.2.2 Derivation process for luma motion vectors for merge mode, a merge candidate consists in the following information: refIdxL0, refIdxL1, predFlagL0, predFlagL1, mvL0, mvL1, hpelIfIdx and bcwIdx.
But it seems that the half sample interpolation filter index hpelIfIdx is never set for Hmvp candidates. According to 8.5.2.16 Updating process for the history-based motion vector predictor candidate list, a candidate in the HMVP list of candidates is defined as: "The MVP candidate hMvpCand consists of the luma motion vectors mvL0 and mvL1, the reference indices refIdxL0 and refIdxL1, the prediction list utilization flags predFlagL0 and predFlagL1, and the bi-prediction weight index bcwIdx." There is no information about the half sample interpolation filter index. Please check!

Change history (1)

comment:1 Changed 3 weeks ago by vdrugeon

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #557.
Sorry, I missed #557 that reports the same issue together with a solution. I marked this one as duplicate of #557.

Note: See TracTickets for help on using tickets.