Opened 3 weeks ago

Closed 3 weeks ago

#602 closed defect (fixed)

Variables in palette mode related text

Reported by: vdrugeon Owned by:
Priority: minor Milestone:
Component: spec Version:
Keywords: Cc: ksuehring, bbross, XiangLi, fbossen, jvet@…

Description

  1. In the syntax of palette coding, the first for loop uses "NumPredictedPaletteEntries[ startComp ] < 31" as one of the conditions to stop the loop. But NumPredictedPaletteEntries is not an array. It is only a variable in the rest of the specification.
  1. The variable PredictorPaletteSize is sometimes used as a simple variable, sometimes as an array. At first sight, it seems to be used only with index startComp when it is used as an array though, so that a simple variable may be enough?
  1. In 8.4.1 General decoding process for coding units coded in intra prediction mode, is it correct to always invoke the palette process with startComp equal to 0, even for chroma dual tree? At first sight, I would have expected that the process should be called with startComp equal to 1 when treeType is equal to DUAL_TREE_CHROMA, same as is done for calling the palette_coding structure in the syntax. If the current text describes the intended behaviour, why is startComp needed at all as input to the palette process, since it is always equal to 0? Please check!

Change history (2)

comment:1 Changed 3 weeks ago by yhchao

Thanks for pointing these out.
Below are the highlight of the suggested fixes:

  1. "NumPredictedPaletteEntries[ startComp ] < 31" should be replaced by "NumPredictedPaletteEntries < 31"
  1. The palette predictor is maintained separately for luma and chroma for dual tree case, so it would be better to have PredictorPaletteSize as an array.
  1. For chroma block, the startComp should be equal to 0 for SINGLE_TREE and equal to 1 for DUAL_TREE_CHROMA.

A corrected spec will be prepared and sent to the editors.

comment:2 Changed 3 weeks ago by bbross

  • Resolution set to fixed
  • Status changed from new to closed

Thanks for reporting and suggesting a fix.

This will be fixed in JVET-P2001-vA.

Note: See TracTickets for help on using tickets.