Opened 4 months ago

Closed 3 months ago

#672 closed defect (fixed)

Inference rule for pt_present_flag[0]

Reported by: vdrugeon Owned by:
Priority: minor Milestone:
Component: spec Version: VVC D7 vE
Keywords: Cc: ksuehring, bbross, XiangLi, fbossen, jvet@…

Description

The inference rule for pt_present_flag[0] seems strange.

pt_present_flag[ i ] equal to 1 specifies that profile, tier, and general constraints information are present in the i-th profile_tier_level( ) syntax structure in the VPS. pt_present_flag[ i ] equal to 0 specifies that profile, tier, and general constraints information are not present in the i-th profile_tier_level( ) syntax structure in the VPS. The value of pt_present_flag[ 0 ] is inferred to be equal to 0. When pt_present_flag[ i ] is equal to 0, the profile, tier, and general constraints information for the i-th profile_tier_level( ) syntax structure in the VPS are inferred to be the same as that for the ( i − 1 )-th profile_tier_level( ) syntax structure in the VPS.

If pt_present_flag[0] is equal to 0, then the profile, tier and general constraints information for the first PTL structure is never signalled. As a consequence, if pt_present_flag[1] is equal to 0, the profile, tier and general constraint information cannot be inferred, because it is not available for the 0-th PTL structure.

At first sight, it seems to make more sense to infer pt_present_flag[0] to be equal to 1.

Change history (5)

comment:1 Changed 4 months ago by bbross

  • Version changed from VVC D7 vB to VVC D7 vC

comment:2 Changed 4 months ago by bbross

  • Version changed from VVC D7 vC to VVC D7 vD

comment:3 Changed 4 months ago by bbross

  • Version changed from VVC D7 vD to VVC D7 vE

comment:4 Changed 3 months ago by vdrugeon

Ticket #695 has been marked as a duplicate of this ticket.

comment:5 Changed 3 months ago by yk

  • Resolution set to fixed
  • Status changed from new to closed

Good catch! Thanks! Fixed in an editorial input prepared by the editors.

Note: See TracTickets for help on using tickets.