Opened 5 years ago

Closed 4 years ago

#757 closed defect (fixed)

LmcsPivot constraint issue

Reported by: wzeng Owned by:
Priority: minor Milestone:
Component: spec Version: VVC D7 vE
Keywords: Cc: ksuehring, bbross, XiangLi, fbossen, jvet@…

Description

In VVC D7 vE, a constraint of LmcsPivot is introduced as below:

It is a requirement of bitstream conformance that, for i = lmcs_min_bin_idx..LmcsMaxBinIdx, when the value of LmcsPivot[ i ] is not a multiple of 32, the value of ( LmcsPivot[ i ] >> ( BitDepth − 5 ) ) shall not be equal to the value of ( LmcsPivot[ i + 1 ] >> ( BitDepth − 5 ) ).

Since the number of segments is fixed, the value "32" should be BitDepth dependent. It should be replaced by "1<<(BitDepth-5)".

Change history (3)

comment:1 Changed 5 years ago by peterchuang

As the proponent of this constraint, we confirmed that the "32" should be modified to "1<<(BitDepth-5)".

comment:2 Changed 5 years ago by abe.kiyo

You are correct. I have confirmed that VTM has been implemented like as your pointing out.

comment:3 Changed 4 years ago by bbross

  • Resolution set to fixed
  • Status changed from new to closed

Thanks for reporting.

This has been fixed in JVET-Q2001-v8.

Note: See TracTickets for help on using tickets.