Opened 3 months ago

Closed 2 months ago

#489 closed defect (fixed)

Mismatch between SW and Spec on enabling PDPC

Reported by: hongbin Owned by:
Priority: minor Milestone:
Component: spec Version:
Keywords: Cc: ksuehring, bbross, XiangLi, fbossen, jvet@…

Description

Suggest to align Spec to SW.

8.4.5.2.5 General intra sample prediction
– One of the following conditions is true:
– predModeIntra is equal to INTRA_PLANAR
– predModeIntra is equal to INTRA_DC
– predModeIntra is less than or equal to INTRA_ANGULAR18
– predModeIntra is less than or equal to INTRA_ANGULAR50

shall be changed to
– One of the following conditions is true:
– predModeIntra is equal to INTRA_PLANAR
– predModeIntra is equal to INTRA_DC
– predModeIntra is less than or equal to INTRA_ANGULAR18
– predModeIntra is greater than or equal to INTRA_ANGULAR50 and is less than INTRA_LT_CCLM

8.4.5.2.14 Position-dependent intra prediction sample filtering process
The variable nScale is derived as follows:
– If predModeIntra is greater than INTRA_ANGULAR50, nScale is set equal to Min( 2, Log2( nTbH ) − Floor( Log2( 3 * invAngle − 2 ) ) + 8 ), using invAngle as specified in clause 8.4.5.2.12.
– Otherwise, if predModeIntra is less than INTRA_ANGULAR18, nScale is set equal to Min( 2, Log2( nTbW ) − Floor( Log2( 3 * invAngle − 2 ) ) + 8 ), using invAngle as specified in clause 8.4.5.2.12.
– Otherwise, nSacle is set to ( ( Log2( nTbW ) + Log2( nTbH ) − 2 ) >> 2 ).

shall be corrected to:
The variable nScale is derived as follows:
– If predModeIntra is greater than INTRA_ANGULAR50, nScale is set equal to Min( 2, Log2( nTbH ) − Floor( Log2( 3 * invAngle − 2 ) ) + 8 ), using invAngle as specified in clause 8.4.5.2.12.
– Otherwise, if predModeIntra is less than INTRA_ANGULAR18 and is not equal to INTRA_PLANAR and is not equal to INTRA_DC, nScale is set equal to Min( 2, Log2( nTbW ) − Floor( Log2( 3 * invAngle − 2 ) ) + 8 ), using invAngle as specified in clause 8.4.5.2.12.
– Otherwise, nSacle is set to ( ( Log2( nTbW ) + Log2( nTbH ) − 2 ) >> 2 ).

Change history (2)

comment:1 Changed 2 months ago by bbross

Ticket #515 has been marked as a duplicate of this ticket.

comment:2 Changed 2 months ago by bbross

  • Resolution set to fixed
  • Status changed from new to closed

Good catch! Thanks!

Fixed in a document we are preparing to be submitted as an editorial input
to the 16th JVET meeting.

Note: See TracTickets for help on using tickets.